All Systems Operational
Exclaimer Cloud: Australia Operational
Mail Routing - Office 365 ? Operational
Mail Routing - Exchange ? Operational
Imprinting ? Operational
Client Side Signatures - Office 365 ? Operational
Data Synchronization ? Operational
Exclaimer Cloud UI ? Operational
Sent Items Update ? Operational
Onboarding ? Operational
Analytics ? Operational
Feedback ? Operational
Exclaimer Cloud: Canada Operational
Mail Routing - Office 365 ? Operational
Mail Routing - Exchange ? Operational
Imprinting ? Operational
Client Side Signatures - Office 365 ? Operational
Data Synchronization ? Operational
Exclaimer Cloud UI ? Operational
Sent Items Update ? Operational
Onboarding ? Operational
Analytics ? Operational
Feedback ? Operational
Exclaimer Cloud: Europe Operational
Mail Routing - Office 365 ? Operational
Mail Routing - G Suite ? Operational
Mail Routing - Exchange ? Operational
Imprinting ? Operational
Client Side Signatures - Office 365 ? Operational
Client Side Signatures - G Suite ? Operational
Data Synchronization ? Operational
Exclaimer Cloud UI ? Operational
Sent Items Update ? Operational
Onboarding ? Operational
Analytics ? Operational
Feedback ? Operational
Exclaimer Cloud: Germany Operational
Mail Routing - Office 365 ? Operational
Mail Routing - Exchange ? Operational
Imprinting ? Operational
Client Side Signatures - Office 365 ? Operational
Data Synchronization ? Operational
Exclaimer Cloud UI ? Operational
Sent Items Update ? Operational
Onboarding ? Operational
Analytics ? Operational
Feedback ? Operational
Exclaimer Cloud: UAE Operational
Mail Routing - Office 365 ? Operational
Mail Routing - Exchange ? Operational
Imprinting ? Operational
Client Side Signatures - Office 365 ? Operational
Data Synchronization ? Operational
Exclaimer Cloud UI ? Operational
Sent Items Update ? Operational
Onboarding ? Operational
Analytics ? Operational
Feedback ? Operational
Exclaimer Cloud: UK Operational
Mail Routing - Office 365 ? Operational
Mail Routing - Exchange ? Operational
Imprinting ? Operational
Client Side Signatures - Office 365 ? Operational
Data Synchronization ? Operational
Exclaimer Cloud UI ? Operational
Sent Items Update ? Operational
Onboarding ? Operational
Analytics ? Operational
Feedback ? Operational
Exclaimer Cloud: US Operational
Mail Routing - Office 365 ? Operational
Mail Routing - G Suite ? Operational
Mail Routing - Exchange ? Operational
Imprinting ? Operational
Client Side Signatures - Office 365 ? Operational
Client Side Signatures - G Suite ? Operational
Data Synchronization ? Operational
Exclaimer Cloud UI ? Operational
Sent Items Update ? Operational
Onboarding ? Operational
Analytics ? Operational
Feedback ? Operational
Portal ? Operational
Outlook Add-In ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Past Incidents
Apr 28, 2024
Resolved - Engineers have confirmed that the previous service alert has been resolved. The maintenance window has completed and certificates have been successfully provisioning again.

The service is now back to full health and is working as normal.

Thank you for your patience.

Apr 28, 01:23 UTC
Update - We are continuing to monitor for any further issues.
Apr 27, 23:37 UTC
Monitoring - Our certificate provider Sectigo is currently carrying out scheduled maintenance. This means that until complete, they are unable to provision new certificates. This is expected to last until 01:00 UTC 28/04. As a result of this, new office 365 tenants attempting to onboard will be unable to complete the mail routing wizard. The status of this maintenance event can be viewed on the sectigo status page here: https://sectigo.status.io/pages/maintenance/5938a0dbef3e6af26b001921/66229e8ef5286d053643a58f

Once the maintenance window has cleared, Engineers will verify the status of certificate provisioning and update accordingly.

Apr 27, 23:36 UTC
Apr 27, 2024
Apr 26, 2024

No incidents reported.

Apr 25, 2024

No incidents reported.

Apr 24, 2024

No incidents reported.

Apr 23, 2024

No incidents reported.

Apr 22, 2024
Resolved - Engineers have confirmed that the previous service alert has been resolved.

The service is now back to full health and is working as normal.

Thank you for your patience.

Apr 22, 19:16 UTC
Update - We are continuing to investigate this issue.
Apr 22, 19:15 UTC
Investigating - Customers may experience slowness or delays when attempting to access their subscription from the Exclaimer web portal.
Signatures that are configured to be applied Client-side or Server-side will continue to be applied as expected.

The cause of the delay is currently being investigated by our Engineering team. Further updates will be provided shortly.

Apr 22, 15:39 UTC
Apr 21, 2024

No incidents reported.

Apr 20, 2024

No incidents reported.

Apr 19, 2024

No incidents reported.

Apr 18, 2024

No incidents reported.

Apr 17, 2024

No incidents reported.

Apr 16, 2024

No incidents reported.

Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.