Service Alert: Potential Access Delays on Exclaimer Web Portal; Signature Application Remains Unaffected
Incident Report for Exclaimer Cloud
Resolved
Engineers have confirmed that the previous service alert has been resolved.

The service is now back to full health and is working as normal.

Thank you for your patience.
Posted Apr 22, 2024 - 19:16 UTC
Update
We are continuing to investigate this issue.
Posted Apr 22, 2024 - 19:15 UTC
Investigating
Customers may experience slowness or delays when attempting to access their subscription from the Exclaimer web portal.
Signatures that are configured to be applied Client-side or Server-side will continue to be applied as expected.

The cause of the delay is currently being investigated by our Engineering team. Further updates will be provided shortly.
Posted Apr 22, 2024 - 15:39 UTC
This incident affected: Exclaimer Cloud: UK (Exclaimer Cloud UI), Exclaimer Cloud: Canada (Exclaimer Cloud UI), and Exclaimer Cloud: Europe (Exclaimer Cloud UI).