UAE - We are investigating a possible service alert.

Incident Report for Exclaimer Cloud

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 09:40 UTC

Monitoring

The previously triggered alert has been mitigated and Engineers have confirmed that the system is stable, though we are continuing to monitor. Customers may have experienced an inability to access the UI for a brief period during this time.
Posted Apr 15, 2025 - 08:41 UTC

Investigating

We are investigating a possible service alert with our services in the UAE region
Posted Apr 15, 2025 - 07:59 UTC
This incident affected: Exclaimer Cloud: UAE (Mail Routing - Office 365, Mail Routing - Exchange, Imprinting, Client Side Signatures - Office 365, Data Synchronization, Exclaimer Cloud UI, Sent Items Update, Onboarding, Analytics, Feedback).