Exclaimer Portal unavailable

Incident Report for Exclaimer Cloud

Resolved

After continued monitoring, we have confirmed there have been no further occurrences of the issue, and the portal is fully operational. A full postmortem will be provided once an in-depth investigation has been completed.

If you are continuing to experience issues within Exclaimer Cloud, please don't hesitate to reach out to our support team, who will be happy to help.
Posted Sep 15, 2025 - 12:21 UTC

Monitoring

Exclaimer Engineering has stabilized the portal and confirmed that the portal can be accessed at a reasonable speed and without error.
We will continue to monitor the page for any signs of further issues
Posted Sep 15, 2025 - 09:36 UTC

Identified

Monitoring and our own testing have indicated that the portal is once again unavailable. Our Engineering team is once again working on restoring service.
Posted Sep 15, 2025 - 08:21 UTC

Monitoring

We are aware of an issue that occurred earlier today that prevented access to the Exclaimer Portal for a period of time.
Remediation action has been taken to restore access to the portal, and our Engineering team is now monitoring the situation.

This has no impact on signatures being applied to messages sent to Exclaimer or for users using the Exclaimer Add-in.
Posted Sep 15, 2025 - 08:13 UTC
This incident affected: Portal.