Signature application taking longer than expected

Incident Report for Exclaimer Cloud

Resolved

This incident has been resolved.
Posted May 12, 2026 - 08:43 UTC

Monitoring

Engineers have confirmed that the issue has been addressed with additional capacity being utilized within the UK.

They are now monitoring for any further issues.
Posted May 11, 2026 - 17:45 UTC

Investigating

Exclaimer Engineers are looking into an issue that will result in customers seeing signatures are applied after a short delay at this time.

More information will be provided when possible.
Posted May 11, 2026 - 17:33 UTC
This incident affected: UK (UK: Server-Side: Signature Application).