Issues accessing Signatures list in Exclaimer portal

Incident Report for Exclaimer Cloud

Resolved

A successful change has addressed the issue, including mitigation to prevent the issue from occurring again. Customers should no longer see any error messages or encounter any issues when accessing the Signatures, Campaigns, or Disclaimers tabs.

If you are experiencing any issues with the Exclaimer Portal, please raise a support ticket, and our team will be happy to help
https://support.exclaimer.com/hc/en-gb/p/raise-ticket
Posted Jul 10, 2026 - 15:52 UTC

Identified

Exclaimer Engineers have identified the cause of the issue and are implementing changes to address the cause.
We have also verified that this issue affected a small subset of customers.
Posted Jul 10, 2026 - 14:39 UTC

Investigating

Exclaimer Engineers are investigating an issue where some customers may receive an 'unexpected error occurred' page when attempting to navigate to the Signatures, Campaigns, or Disclaimers tabs.

If you are experiencing this issue, please raise a support ticket using the link below.
https://support.exclaimer.com/hc/en-gb/p/raise-ticket

Signatures are continuing to be applied as expected to messages through both the mail flow rule and the Exclaimer add-in.
Posted Jul 10, 2026 - 11:03 UTC