Our engineers have confirmed this issue was caused by a change on Google's side, that we have implemented a code change to mitigate and will continue to work with Google to address the issue.
Posted Sep 22, 2026 - 15:58 UTC
Update
We are continuing to investigate this issue.
Posted Sep 22, 2026 - 10:15 UTC
Investigating
Exclaimer engineers are investigating a delivery delay affecting some messages sent from Gmail/Google Workspace to Exclaimer Cloud. Some of these messages may be retried by the sender and may appear as temporary deferrals rather than delivery failures. We are not currently aware of any confirmed message loss and will provide updates as we learn more.
Posted Sep 22, 2026 - 10:08 UTC
This incident affects: US (US: Server-Side: Mail Routing - Google Workspace), Europe (EU: Server-Side: Mail routing - Google Workspace), and Germany (DE: Server-Side: Mail Routing - Google Workspace).