Issues authenticating for customers using Sectigo
Incident Report for Exclaimer Cloud
Resolved
This incident has been resolved.
Posted Oct 07, 2024 - 15:09 UTC
Monitoring
We are monitoring the issue
Posted Oct 07, 2024 - 14:45 UTC
Identified
The issue has been identified: Sectigo is currently down, and according to their status page, the problem is being worked on.
Posted Oct 07, 2024 - 14:39 UTC
This incident affected: Exclaimer Cloud: Europe (Mail Routing - Office 365) and Exclaimer Cloud: UK (Mail Routing - Office 365).