Customers unable to provision tenant certificates during onboarding
Incident Report for Exclaimer Cloud
Resolved
Engineers have confirmed that the previous service alert has been resolved. The maintenance window has completed and certificates have been successfully provisioning again.

The service is now back to full health and is working as normal.

Thank you for your patience.
Posted Mar 24, 2024 - 03:29 UTC
Monitoring
Our certificate provider Sectigo is currently carrying out scheduled maintenance. This means that until complete, they are unable to provision new certificates. This is expected to last until 03:00 UTC 24/03. As a result of this, new office 365 tenants attempting to onboard will be unable to complete the mail routing wizard. The status of this maintenance event can be viewed on the sectigo status page here: https://sectigo.status.io/pages/maintenance/5938a0dbef3e6af26b001921/65f48a9351261305827a8ad2

Once the maintenance window has cleared, Engineers will verify the status of certificate provisioning and update accordingly.
Posted Mar 24, 2024 - 01:39 UTC
This incident affected: Exclaimer Cloud: UK (Onboarding), Exclaimer Cloud: Australia (Onboarding), Exclaimer Cloud: Canada (Onboarding), Exclaimer Cloud: UAE (Onboarding), Exclaimer Cloud: Germany (Onboarding), Exclaimer Cloud: Europe (Onboarding), and Exclaimer Cloud: US (Onboarding).