Images not appearing in signature tests.

Incident Report for Exclaimer Cloud

Resolved

This incident has been resolved. Web-hosted images in the signature editor are now loading correctly across all regions.
A recent update to the cloud UI's Content Security Policy inadvertently restricted external image sources, causing hosted images to fail to display. The policy has been updated to allow the required image sources, and the fix has been deployed to all production regions. We're monitoring to confirm stability.
We apologize for any disruption this caused.
Posted Jun 23, 2026 - 08:01 UTC

Investigating

Exclaimer engineers are aware of an issue causing some images not to appear within the signature tester result when a test is run.
The same images appear as expected in the signature designer and in live messages.

There is no impact on email signatures, as these images are applied as expected.
Posted Jun 22, 2026 - 19:01 UTC