Our engineers have escalated the urgency of this with Microsoft and continue to push for updates as soon as possible.
Posted Jun 24, 2026 - 12:51 UTC
Identified
Customers in the AU and US may experience issues with emails being quarantined by Microsoft defender due to false positive phishing detection. Our engineers are working with Microsoft to have the domain reputation cleared as soon as possible.
Posted Jun 23, 2026 - 16:33 UTC
This incident affects: Australia (AU: Analytics: Click Tracking) and US (US: Analytics: Click Tracking).