No further issues with mail flow have been identified over the weekend that were caused by this incident. If you are continuing to experience issues with your Exclaimer Subscription, please don't hesitate to reach out, and our team will be more than happy to assist.
Posted Jan 26, 2026 - 14:33 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 23, 2026 - 06:38 UTC
Monitoring
We have confirmed that Microsoft has deployed a fix to address the issue and confirmed resolution for Incident (MO1221364). We are continuing to monitor the service for stability.
Posted Jan 23, 2026 - 06:32 UTC
Investigating
We are currently investigating an issue affecting email delivery within our Exclaimer services. Email routed through Exchange Online may be impacted due to an ongoing Microsoft incident (MO1221364).
Posted Jan 23, 2026 - 02:39 UTC
This incident affected: Europe (EU: Server-Side: Mail Routing - Office 365), US (US: Server-Side: Mail Routing - Office 365), Canada (CA: Server-Side: Mail Routing - Office 365), UAE (UAE: Server-Side: Mail Routing - Office 365), Australia (AU: Server-Side: Mail Routing - Office 365), UK (UK: Server-Side: Mail Routing - Office 365), and Germany (DE: Server-Side: Mail Routing - Office 365).