Automated certificate renewals are failing

Incident Report for Exclaimer Cloud

Resolved

We have had confirmation that Sectigo have resolved the incident, and can conform all services are running as normal.
Posted Mar 15, 2025 - 06:51 UTC

Monitoring

Certificates are provisioning as normal once again. Failed renewals will be retried by our automated system, and our records show no new sign-ups were affected. We will continue to monitor the situation
Posted Mar 15, 2025 - 05:44 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 15, 2025 - 05:00 UTC

Identified

We have identified an issue with our SSL certificate provider Sectigo that is affecting issuance of SSL certificates. This is mostly affecting certificate renewals, however it may also affect new sign-ups attempting to setup the server-side product.
This is not having any impact on mail flow, and regular product function remains working as normal.
Posted Mar 15, 2025 - 04:44 UTC