We are investigating a possible service alert.
Incident Report for Exclaimer Cloud
Resolved
Engineers have confirmed that the previous service alert has been resolved.

The service is now back to full health and is working as normal.

Thank you for your patience.
Posted Nov 22, 2024 - 03:01 UTC
Update
Engineers have confirmed that the previous service alert has been resolved. The service is now back to full health and is working as normal. Thank you for your patience.
Posted Nov 22, 2024 - 01:58 UTC
Update
We are continuing to investigate this issue.
Posted Nov 22, 2024 - 01:29 UTC
Investigating
We are investigating a possible service alert.

Exclaimer Cloud - Add-in is not applying signatures as expected on Outlook 365 Desktop(Classic), we are currently investigating the issue.
Posted Nov 22, 2024 - 01:26 UTC
This incident affected: Exclaimer Cloud: UK (Client Side Signatures - Office 365), Exclaimer Cloud: Australia (Client Side Signatures - Office 365), Exclaimer Cloud: Canada (Client Side Signatures - Office 365), Exclaimer Cloud: UAE (Client Side Signatures - Office 365), Exclaimer Cloud: Germany (Client Side Signatures - Office 365), Exclaimer Cloud: Europe (Client Side Signatures - Office 365), Exclaimer Cloud: US (Client Side Signatures - Office 365), and Outlook Add-In.