The issue is now resolved and the all mail flow processing is operational
Posted Jul 01, 2026 - 15:41 UTC
Monitoring
Exclaimer engineers have applied a fix to address the issue, ensuring no further messages will be affected. Any messages that were impacted would have been deferred for delivery and would be sent rather than failing to be delivered entirely.
We will continue to monitor and provide further updates in the next hour.
Posted Jul 01, 2026 - 12:10 UTC
Identified
Exclaimer engineers are aware of an issue where messages within the UK may be impacted and fail to be delivered at this time.
The team is actively working to address the issue
Posted Jul 01, 2026 - 11:45 UTC
This incident affected: UK (UK: Server-Side: Mail Routing - Office 365).