Signature Designer not accessible, redirecting to Home

Incident Report for Exclaimer Cloud

Resolved

Engineers have confirmed that the previous service alert has been resolved.

The service is now back to full health and is working as normal.

Thank you for your patience.
Posted Aug 20, 2026 - 16:08 UTC

Monitoring

Exclaimer engineers have resolved the issue, and customers should no longer experience any issues when using the Signature Designer.

We are now monitoring for any further issues.
Posted Aug 20, 2026 - 12:59 UTC

Investigating

Engineers are aware of an issue affecting the Signature Designer, which is preventing some customers from editing signature templates. There is no impact to mail flow or signature delivery at this time. We are investigating and will provide a further update within 60 minutes.
Posted Aug 20, 2026 - 12:34 UTC
This incident affected: UK (UK: UI: Admin User Interface), Australia (AU: UI: Admin User Interface), Canada (UI: Admin User Interface), UAE (UAE: UI: Admin User Interface), Germany (DE: UI: Admin User Interface), Europe (EU: UI: Admin User Interface), and US (US: UI: Admin User Interface).