Exclaimer Cloud: Unexpected Error when using Add-in on MacOS devices
Incident Report for Exclaimer Cloud
Postmortem

Issue: Crash Error log generated by the Add-in within Outlook for Mac

Incident Length: 1 Hour 29 minutes

Incident Date: 12/11/2024, UTC 16:29 – 17:58

Incident Status: Resolved

Summary

An update to the Exclaimer Add-in resulted in MacOS Outlook installations running the Add-in to report a crash when composing a message. There was no reported impact for customers using Server-side Signatures or Client-side on Windows OS’, or Outlook on the Web, or Mobile devices.

Root Cause

An update to the Exclaimer Add-in, to apply Client-side signatures, to add support for Nested App Authentication (NAA) resulted in MacOS 15 users running the Add-in to report a crash when composing a message in Outlook for Mac.

Initial investigation has indicated that this looks to potentially be an issue within the Outlook for Mac application at this time, and this has been raised for further investigation with Microsoft.

 

Mitigation

To resolve the issue, a roll back process to revert the update to support NAA began was enacted. This roll back was completed quickly and without further issues. Due to caching of Add-in data within local Outlook clients, continued monitoring of reports was done by our Support Team to confirm that the disruption to service was resolved for our impacted customers.

An internal review of the testing and deployment has been undertaken in response to this, to determine improvements that may be made in these processes to prevent this from happening again.

Incident Timeline

14:36 – v1.22.100.219 of the Exclaimer Add-in is deployed

16:30 – Reports from customers of Crashing being seen within Mac for Outlook when composing emails.

16:51 – Exclaimer Support confirm replication of the issue and the scope of the fault.

17:23 – Rollback of Add-in globally begins.

17:37 – Rollback is Completed for all regions

17:58 – Support confirm that impacted customers are no longer experiencing the issue.

Posted Nov 15, 2024 - 09:50 UTC

Resolved
On the 12th November at 16:29 UTC, an update for the Exclaimer Add-in was released that resulted in Mac devices to report a Crash when attempting to apply a signature. This issue was resolved by 17:37 UTC with a full roll back to the previous version of the Add-in.

Customer using the Add-in on Windows OS', Outlook on the Web, or Mobile Devices where not impacted. Additionally Server-side signatures continued to apply as expected.
Posted Nov 15, 2024 - 09:33 UTC