Potential Mail Delays in US

Incident Report for Exclaimer Cloud

Resolved

Our engineers monitored over the weekend and mail flow as been progressing as normal.
Posted Aug 03, 2026 - 07:21 UTC

Monitoring

The applied preventive messages have effectively stabilized the potential delay. Engineers are continuing to monitor for any signs of further issues.
Posted Jul 31, 2026 - 13:26 UTC

Investigating

Exclaimer Engineers are investigating a potential mail flow delivery issue within the US region at this time.
Preventive action has been taken to mitigate the issue, and more information will be provided when possible.
Posted Jul 31, 2026 - 12:59 UTC