Issues completing Exclaimer Cloud setup - Microsoft 365

Incident Report for Exclaimer Cloud

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 09:39 UTC

Investigating

Exclaimer Engineers are investigating a possible issue that may impact some customers who are configuring Exclaimer Cloud for Microsoft 365.

The issue is not expected to impact a larger number of customers, and re-running the setup should resolve the issue. If you are having issues with the setup, please reach out to our Support Team, who will be able to assist.
Posted Mar 04, 2026 - 14:19 UTC
This incident affected: UK (UK: UI: New Customer Onboarding), Australia (AU: UI: New Customer Onboarding), Canada (UI: New Customer Onboarding), UAE (UAE: UI: New Customer Onboarding), Germany (DE: UI: New Customer Onboarding), Europe (EU: UI: New Customer Onboarding), and US (US: UI: New Customer Onboarding).