Exclaimer Add-In Preview Error
Incident Report for Exclaimer Cloud
Postmortem

Issue: Exclaimer Add-In Preview Error

Incident Length: 1 hour and 18 minutes

Incident Date: Jan 15, 2025 01:18 am UTC to Jan 15, 2025 02:19 am UTC

Incident Status: Resolved

Summary

Customers reported encountering error “Page Not Found” with Exclaimer Add-In Preview pane. Customers are still able to utilise Add In auto apply. This issue has impacted all regions' subscriptions.

Going forwards, an action group rule in Azure service health has been created to send alerts internally when there are service issues, planned maintenance, health or security advisory alerts to prevent similar issues in the future.

Root Cause

Due to the domain validation on the CDN failing during the migration, the add-in failed to connect to the endpoint. This resulted in the preview pane not displaying any signatures, and displaying the 'Page Not Found' error.

Incident Timeline

01:18am UTC – Alerting advised to a failure to preview signatures in Exclaimer Add In preview pane.

01:30am UTC – Investigation indicated that the domain validation on the CDN failed during the migration.

01:50am UTC – Engineering confirmed that the preview pane is back up.

02:19am UTC – Several customers confirmed that issue is resolved status changed to resolved.

Posted Jan 22, 2025 - 07:10 UTC

Resolved
Engineers have confirmed that the previous service alert has been resolved.

The service is now back to full health and is working as normal.

Thank you for your patience.
Posted Jan 15, 2025 - 02:19 UTC
Investigating
Exclaimer Add-In Preview pane is displaying "Page Not Found". Customers are still able to utilise Add In auto apply.
Posted Jan 15, 2025 - 01:11 UTC
This incident affected: Exclaimer Cloud: UK (Client Side Signatures - Office 365), Exclaimer Cloud: Australia (Client Side Signatures - Office 365), Exclaimer Cloud: Canada (Client Side Signatures - Office 365), Exclaimer Cloud: UAE (Client Side Signatures - Office 365), Exclaimer Cloud: Germany (Client Side Signatures - Office 365), Exclaimer Cloud: Europe (Client Side Signatures - Office 365), Exclaimer Cloud: US (Client Side Signatures - Office 365), and Outlook Add-In.