The incident has been resolved by our engineers and mail routing is operational across all regions. Customers may have experience mail delivery delays but these would have been delivered following retries.
Posted Jun 29, 2026 - 08:51 UTC
Monitoring
We have mitigated the issue and mail flow is working again in all regions. We are monitoring now to ensure this has resolved the issue.
Posted Jun 29, 2026 - 08:26 UTC
Identified
Our engineers have identified the issue and are mitigating. Customers may still experience delays in mail delivery
Posted Jun 29, 2026 - 08:00 UTC
Investigating
We were alerted to an issue with mail flow in our primary data centers. Our engineers are currently investigating and trying to resolve asap
Posted Jun 29, 2026 - 07:35 UTC
This incident affected: Europe (EU: Server-Side: Mail Routing - Office 365, EU: Server-Side: Mail routing - Google Workspace, EU: Server-Side: Mail Routing - Exchange), US (US: Server-Side: Mail Routing - Office 365, US: Server-Side: Mail Routing - Google Workspace, US: Server-Side: Mail Routing - Exchange), Canada (CA: Server-Side: Mail Routing - Office 365, CA: Server-Side: Mail Routing - Exchange), UAE (UAE: Server-Side: Mail Routing - Office 365, UAE: Server-Side: Mail Routing - Exchange), Australia (AU: Server-Side: Mail Routing - Office 365, AU: Server-Side: Mail Routing - Exchange), UK (UK: Server-Side: Mail Routing - Office 365, UK: Server-Side: Mail Routing - Exchange), and Germany (DE: Server-Side: Mail Routing - Office 365, DE: Server-Side: Mail Routing - Exchange).