Engineers have confirmed that the previous service alert has been resolved.
The service is now back to full health and is working as normal.
Thank you for your patience.
Posted Mar 18, 2026 - 08:34 UTC
Monitoring
We have identified what was behind the degraded service in the UK and have put a fix in place to remediate the issue. Mail routing has returned to a stable state and we are currently monitoring the situation
Posted Mar 18, 2026 - 08:10 UTC
Investigating
We are currently investigating this issue.
Posted Mar 17, 2026 - 22:59 UTC
This incident affected: UK (UK: Server-Side: Mail Routing - Office 365, UK: Server-Side: Mail Routing - Exchange).