Microsoft have confirmed that the original issue impacting customers was the result of a server-side change that has since been reverted.
Our telemetry also confirms that over 40% of customer requests are coming from the newly released version that similarly resolved customer issues prior to Microsoft's deployment reversal, this continues to roll out. We intend to leave this fix in place as it improves the add-ins resilience to possible authentication issues.
If you are currently experiencing any further issues with Exclaimer, please contact our Support team for assistance.
Posted May 29, 2026 - 10:47 UTC
Update
We continue to see a reduction of errors as the new version rolls out and are monitoring its progress.
Please note that the speed of adoption may vary depending on Outlook cache.
If you are currently experiencing any further issues with Exclaimer, please contact our Support team for assistance.
Posted May 28, 2026 - 16:04 UTC
Monitoring
Engineering has successfully tested and deployed a fix for the add-in to resolve this issue. We will continue to closely monitor the add-in’s performance following the release.
Please note that the speed of adoption may vary depending on Outlook cache.
If you are currently experiencing any further issues with Exclaimer, please contact our Support team for assistance.
Posted May 28, 2026 - 14:17 UTC
Identified
Our team have identified the issue and are actively working on a resolution.
Further updates will follow once a fix has been identified.
Posted May 28, 2026 - 12:16 UTC
Investigating
Engineers are aware of an issue impacting our ability to apply signatures to messages as they are composed, the message 'Failed to acquire auth token' is displayed. There is no impact to email delivery at this time, once the issue has been resolved signatures will start to be applied again.
If you have our server-side offering configured, then you will find that signatures are applied to messages after they are sent.
If you have any other issues, please contact our support team who will be happy to help