Delivery delays for messages sent from Outlook and Exchange

Incident Report for Exclaimer Cloud

Identified

Exclaimer has identified that a small subset of messages (~0.02%) are delayed when routed through Exclaimer due to a suspected issue within Microsoft's servers. This has been raised with Microsoft to investigate alongside Exclaimer Engineers.
Sent messages will be received with a signature applied, as expected.

If you are seeing issues with message deliverability, please reach out to our support team, who will be happy to assist.
Posted Sep 22, 2026 - 15:19 UTC

Investigating

Exclaimer engineers are investigating a delivery delay affecting some messages sent from Outlook and Exchange to Exclaimer Cloud. Some of these messages may be retried by the sender and may appear as temporary deferrals rather than delivery failures. We are not currently aware of any confirmed message loss and will provide updates as we learn more.
Posted Sep 22, 2026 - 10:58 UTC
This incident affects: Europe (EU: Server-Side: Mail Routing - Office 365, EU: Server-Side: Mail Routing - Exchange), US (US: Server-Side: Mail Routing - Office 365, US: Server-Side: Mail Routing - Exchange), Canada (CA: Server-Side: Mail Routing - Office 365, CA: Server-Side: Mail Routing - Exchange), UAE (UAE: Server-Side: Mail Routing - Office 365, UAE: Server-Side: Mail Routing - Exchange), Australia (AU: Server-Side: Mail Routing - Office 365, AU: Server-Side: Mail Routing - Exchange), UK (UK: Server-Side: Mail Routing - Office 365, UK: Server-Side: Mail Routing - Exchange), and Germany (DE: Server-Side: Mail Routing - Office 365, DE: Server-Side: Mail Routing - Exchange).