Exclaimer Cloud pages not loading as expected

Incident Report for Exclaimer Cloud

Monitoring

Our engineers have resolved the issue, and customers should no longer experience any issues when using the Exclaimer Cloud Portal. We are now monitoring to ensure stability remains.

If you are continuing to see issues, please don't hesitate to contact our support team, who will be happy to help.
Posted Aug 18, 2026 - 10:39 UTC

Investigating

Exclaimer Engineers are aware of a transient issue that may cause certain pages, such as Branding, Campaigns, and Disclaimers, to fail to load for customers within the Exclaimer Portal.
Remediation work is underway to restore access to these sections of the portal.

Signatures are still being applied to Emails. If you are seeing that signatures are not being applied, please contact our support team, who will be happy to help.
Posted Aug 18, 2026 - 08:31 UTC
This incident affects: UK (UK: UI: Admin User Interface), Australia (AU: UI: Admin User Interface), Canada (UI: Admin User Interface), UAE (UAE: UI: Admin User Interface), Germany (DE: UI: Admin User Interface), Europe (EU: UI: Admin User Interface), and US (US: UI: Admin User Interface).