Imprint failures in US1 datacenter

Incident Report for Exclaimer Cloud

Resolved

This incident has been resolved.
Posted Aug 05, 2026 - 06:34 UTC

Monitoring

Imprinting has now recovered and is operationsl once more. Engineers will continue to monitor the situation.
Posted Aug 04, 2026 - 19:54 UTC

Identified

We have identified an issue with the auto scaling on key services. These have been manually scaled and we are seeing recovery.
Posted Aug 04, 2026 - 19:38 UTC

Investigating

We are currently seeing an increase in imprint failures for messages processed in the US1 datacenter.
Posted Aug 04, 2026 - 19:14 UTC
This incident affected: US (US: Client Side: Signature Application - Office 365, US: Client Side: Signature Application - Google Workspace).