Exclaimer Cloud Portal not loading as expected

Incident Report for Exclaimer Cloud

Resolved

After extended monitoring, our engineers have not seen any further issues stopping customers from accessing our Portal. This weekends planned maintenance work will continue as planned as part of this work will help address the stability of the Portal and improve accessibility for customers in the future.

If you have any questions or concerns, please don't hesitate to contact our great support team, who will be happy to help.
Posted Feb 05, 2026 - 18:26 UTC

Monitoring

A fix has been implemented, and access to our portal has been restored. Our Engineering team is now monitoring the service for any further issues.
Posted Feb 04, 2026 - 14:07 UTC

Investigating

Exclaimer Engineers are aware that the Portal is not loading as expected for customers again after an earlier issue. This is being looked into as a high priority for our team.

This issue does not impact signature rules, and signatures continued to be applied to users as expected during the issue.

If you have any questions or concerns, please reach out to our support team, who will be happy to assist.
Posted Feb 04, 2026 - 13:52 UTC
This incident affected: UI: Authentication and Billing Portal.