Azure service has been restored, and services have scaled up as required, we are no longer seeing any issues within our service as a consequence.
If you are continuing to experience issues within Exclaimer at this time, please don't hesitate to reach out to our support team, who will be happy to help!
Posted Feb 02, 2026 - 23:59 UTC
Monitoring
Scaling capability appears to have been restored by Microsoft, we're now monitoring our service to ensure it recovers to full capacity.
Posted Feb 02, 2026 - 23:33 UTC
Identified
Exclaimer engineers have identified a global issue with Azure that is impacting our ability to handle messages, as new compute resource cannot currently be created to handle demand, and as such customers in AU might experience issues with message delivery.
You can look to disable the Mail flow rule ‘Identify messages to send to Exclaimer Cloud’ to restore mail flow.
We will continue to monitor the performance to ensure that the service fully recovers, and provide any updates received by Microsoft. They currently anticipate the fix for this will be in place by 00:00 UTC.
If you are experiencing any other issues with Exclaimer at this time, please contact our support team right away.
Posted Feb 02, 2026 - 23:10 UTC
This incident affected: Australia (AU: Server-Side: Mail Routing - Office 365).