Issues accessing Exclaimer Portal for some users

Incident Report for Exclaimer Cloud

Identified

Exclaimer Engineers have identified the cause of the issue and are currently working on a solution.

Further updates will be provided once this is released.
Posted Apr 01, 2026 - 12:06 UTC

Investigating

We are currently investigating an issue with some users not being able to access the Exclaimer Portal when choosing Launch, where the portal gets caught on a loading page.
The issue does not appear to affect all users and all subscriptions at this time
Posted Apr 01, 2026 - 10:31 UTC