Message processing issues in EU

Incident Report for Exclaimer Cloud

Resolved

The Azure SQL database in EU2 has been fully restored by Microsoft. EU2 endpoints have been re-enabled and mailflow is balanced. All services are confirmed healthy with no further impact to customers.
Posted May 28, 2026 - 13:12 UTC

Monitoring

Exclaimer Engineers have successfully mitigated the issue and mailflow had returned to normal levels.
Posted May 28, 2026 - 09:03 UTC

Identified

Issue: An Azure storage failure in EU2 is resulting in delays processing messages there, engineering teams are actively mitigating the issue.

Symptoms: Some messages processed in EU could be delayed.

Next Update In: 30 mins or less
Posted May 28, 2026 - 08:40 UTC
This incident affected: Europe (EU: Server-Side: Mail Routing - Office 365, EU: Server-Side: Mail routing - Google Workspace).