UK Server-side IP appearing on Sender Score Return Path Blocklist

Incident Report for Exclaimer Cloud

Resolved

No issues have occurred since our last update, and we will now mark this incident as resolved.

If you require any assistance, please contact our support team, who will be more than happy to help.
Posted Feb 03, 2026 - 12:06 UTC

Monitoring

Monitoring has indicated there has been no impact from the listing, and the IP has not been added back onto the list at this time. Our Engineers will continue to monitor for any further reports.
Posted Feb 02, 2026 - 15:11 UTC

Investigating

Exclaimer Engineers are aware of a relay IP address within the UK having been added to the Sender Score Return Path Blocklist. The IP is no longer reporting as being on this list. We have reached out to obtain more information.

Client-side signatures are unaffected by this issue.

If you are experiencing issues with mail flow at this time, we advise you to disable the Exclaimer Mail flow rule within the Exchange Admin Center and to contact our support team who will be more than happy to help.
Posted Feb 02, 2026 - 14:18 UTC
This incident affected: UK (UK: Server-Side: Mail Routing - Office 365).