A fix has been implemented and we are monitoring the results.
Posted May 18, 2025 - 12:01 UTC
Identified
We are continuing to work on a fix for this issue.
Posted May 18, 2025 - 12:00 UTC
Monitoring
Although we are still awaiting final confirmation from our certificate issuance partner, our engineers have noted that certificates are now beginning to be processed as normal again. We will continue to monitor
Posted May 18, 2025 - 11:07 UTC
Identified
We have identified an issue with our certificate provider that is causing certificate requests to fail. This will impact new sign-ups to our server-side service, prevennting them from completing setup.
Posted May 18, 2025 - 04:45 UTC
This incident affected: Exclaimer Cloud: UK (Onboarding), Exclaimer Cloud: Australia (Onboarding), Exclaimer Cloud: Canada (Onboarding), Exclaimer Cloud: UAE (Onboarding), Exclaimer Cloud: Germany (Onboarding), Exclaimer Cloud: Europe (Onboarding), and Exclaimer Cloud: US (Onboarding).