All services have been fully restored across the US region. Email signature delivery is operating normally in both US datacenters following the Azure West US infrastructure outage on 23 July 2026.
We apologise for any disruption caused.
Posted Jul 24, 2026 - 08:45 UTC
Update
Email signature delivery has been restored for customers in the US region. While the underlying issue was with Azure's West US infrastructure, we made adjustments to our systems to mitigate the impact and maintain service during the outage.
We are continuing to monitor the situation. Please contact support if you experience any further issues.
We apologise for any inconvenience caused.
Posted Jul 23, 2026 - 20:06 UTC
Monitoring
Email signature delivery has been restored for customers in the US region. While the underlying issue was with Azure's West US infrastructure, we made adjustments to our systems to mitigate the impact and maintain service during the outage.
We are continuing to monitor the situation while Microsoft investigate the underlying Azure West US infrastructure issue.
Posted Jul 23, 2026 - 17:20 UTC
Update
Update - 23 Jul 2026, 18:15 BST
We have restored email signature delivery for customers in the US region. Emails are now being delivered with signatures applied.
We are continuing to monitor the situation while Microsoft investigate the underlying Azure West US infrastructure issue. We will provide a further update if any impact is detected.
We apologise for any inconvenience caused.
Posted Jul 23, 2026 - 17:19 UTC
Update
Update - 23 Jul 2026, 17:20 BST
We continue to investigate an issue affecting email signature delivery for customers in the US region, caused by an external Azure infrastructure issue in West US.
Email is still being delivered. Signatures may intermittently not be applied during this window. We have scaled our US infrastructure and are actively working to restore full service.
Posted Jul 23, 2026 - 16:28 UTC
Update
We are continuing to investigate this issue.
Posted Jul 23, 2026 - 15:35 UTC
Investigating
We are currently experiencing issues with email signature delivery for customers in the US region due to an underlying Azure infrastructure issue in West US. Emails are being delivered but signatures may not be applied during this window. We are actively working to restore full service and will provide updates every 30 minutes.
Posted Jul 23, 2026 - 15:32 UTC
This incident affected: US (US: Server-Side: Signature Application).