Delayed message delivery and signature imprinting issues

Incident Report for Exclaimer Cloud

Resolved

Email signature delivery is operating normally in the US again after mitigation by engineers. Between 14:20 and 14:54 UTC, customers may have experienced some minor delays whilst imprinting was retried internally and a small number of messages may have been delivered without a signature applied.

We apologise for any disruption caused.
Posted Sep 08, 2026 - 15:54 UTC

Monitoring

Engineers have applied a mitigation for the issue affecting mail processing that began at 14:37 UTC. Some messages experienced delays while imprinting was retried, and a small number of messages may have been sent without a signature applied. Our engineering team is continuing to monitor performance to confirm full recovery.
Posted Sep 08, 2026 - 15:02 UTC
This incident affected: US (US: Server-Side: Signature Application).