Exclaimer Engineers are continuing to investigate issues affecting customers in the MEA region who are facing delays or deferrals when sending emails.
Our findings indicate that Exclaimer itself is functioning properly in the region, and successful connections are being established for all incoming messages. Occasionally, we notice that our monitoring systems initiate a connection but then disconnect before completing the message transfer. Since these cases don't reach our servers, it suggests that the problem is likely outside of Exclaimer's framework, occurring when the sending email server attempts to route messages.
We have contacted Microsoft to further investigate the situation.
For customers experiencing delays in mail flow, an immediate workaround is to disable the Exchange Mail Flow rules. Despite the delays, we confirm that all messages are eventually being processed by Exclaimer as expected.
Posted Apr 04, 2026 - 14:44 UTC
Investigating
Exclaimer Engineers are investigating a possible issue for customers in the MEA region who are unable to route emails to Exclaimer for Server-Side signatures, with messages being deferred and delayed.
Emails are continuing to be processed. If any possible sending delay needs to be avoided, you can disable the Mail flow rules for Exclaimer Cloud within the Exchange Admin Center.
This does not look to impact all customers within the region. More information will be provided when available.
Posted Apr 04, 2026 - 10:00 UTC
This incident affects: UAE (UAE: Server-Side: Mail Routing - Office 365).