Microsoft has announced that the service has now been restored, and any messages impacted will resume periodic attempts to be delivered at this stage.
If you are seeing issues relating to signatures not being applied to messages as expected, please don't hesitate to reach out to our support team, who will be happy to help.
Posted Aug 29, 2025 - 15:54 UTC
Monitoring
Exclaimer Engineers are beginning to see evidence that Microsoft Exchange is starting to recover, and previously deferred messages are now being sent and received as expected.
Messages that had been routed to Exclaimer will be delivered with a signature as expected, once they are accepted by Microsoft Exchange. We've confirmed there is no impact to our systems and that Exclaimer continues to operate as expected.
We will continue to monitor email flow for any signs of relapses in Exchange Online over the rest of the day.
Posted Aug 29, 2025 - 15:04 UTC
Update
Exclaimer is continuing to monitor the issue at this stage. Customers who are unable to access the Admin Center for incident EX1144276 within Exchange Online can monitor the Microsoft 365 Status account on X for updates: https://x.com/msft365status/status/1961409977400132058
Posted Aug 29, 2025 - 14:45 UTC
Identified
Microsoft is investigating an issue in Europe where some users may experience delays when sending and receiving email messages. For more details, please look for EX1144276 within the Microsoft admin center.
The mail flow delays are not caused by any system provided by Exclaimer, but we will continue to monitor the service and advise once we hear more.
If you have any other questions or concerns, please reach out to our support team. They will be happy to help.