Duplicate Payment Issue

Incident Report for Exclaimer Cloud

Update

We have now contacted the impacted customers directly to confirm that the refund for the duplicate transaction is underway and to provide more information on the issue.
Posted Dec 19, 2025 - 09:26 UTC

Identified

Exclaimer is aware of an error that has resulted in duplicate payments being taken from some customers this month.
We are in the process of refunding all duplicate payments; these should be returned within seven(7) business days.

We apologise for any inconvenience that may have occurred. More information will be provided directly to impacted customers.
Posted Dec 18, 2025 - 10:27 UTC