All Systems Operational
Exclaimer Cloud: Australia Operational
Mail Routing - Office 365 ? Operational
Mail Routing - Exchange ? Operational
Imprinting ? Operational
Client Side Signatures - Office 365 ? Operational
Data Synchronization ? Operational
Exclaimer Cloud UI ? Operational
Sent Items Update ? Operational
Onboarding ? Operational
Analytics ? Operational
Feedback ? Operational
Exclaimer Cloud: Canada Operational
Mail Routing - Office 365 ? Operational
Mail Routing - Exchange ? Operational
Imprinting ? Operational
Client Side Signatures - Office 365 ? Operational
Data Synchronization ? Operational
Exclaimer Cloud UI ? Operational
Sent Items Update ? Operational
Onboarding ? Operational
Analytics ? Operational
Feedback ? Operational
Exclaimer Cloud: Europe Operational
Mail Routing - Office 365 ? Operational
Mail Routing - G Suite ? Operational
Mail Routing - Exchange ? Operational
Imprinting ? Operational
Client Side Signatures - Office 365 ? Operational
Client Side Signatures - G Suite ? Operational
Data Synchronization ? Operational
Exclaimer Cloud UI ? Operational
Sent Items Update ? Operational
Onboarding ? Operational
Analytics ? Operational
Feedback ? Operational
Exclaimer Cloud: Germany Operational
Mail Routing - Office 365 ? Operational
Mail Routing - Exchange ? Operational
Imprinting ? Operational
Client Side Signatures - Office 365 ? Operational
Data Synchronization ? Operational
Exclaimer Cloud UI ? Operational
Sent Items Update ? Operational
Onboarding ? Operational
Analytics ? Operational
Feedback ? Operational
Exclaimer Cloud: UAE Operational
Mail Routing - Office 365 ? Operational
Mail Routing - Exchange ? Operational
Imprinting ? Operational
Client Side Signatures - Office 365 ? Operational
Data Synchronization ? Operational
Exclaimer Cloud UI ? Operational
Sent Items Update ? Operational
Onboarding ? Operational
Analytics ? Operational
Feedback ? Operational
Exclaimer Cloud: UK Operational
Mail Routing - Office 365 ? Operational
Mail Routing - Exchange ? Operational
Imprinting ? Operational
Client Side Signatures - Office 365 ? Operational
Data Synchronization ? Operational
Exclaimer Cloud UI ? Operational
Sent Items Update ? Operational
Onboarding ? Operational
Analytics ? Operational
Feedback ? Operational
Exclaimer Cloud: US Operational
Mail Routing - Office 365 ? Operational
Mail Routing - G Suite ? Operational
Mail Routing - Exchange ? Operational
Imprinting ? Operational
Client Side Signatures - Office 365 ? Operational
Client Side Signatures - G Suite ? Operational
Data Synchronization ? Operational
Exclaimer Cloud UI ? Operational
Sent Items Update ? Operational
Onboarding ? Operational
Analytics ? Operational
Feedback ? Operational
Portal ? Operational
Outlook Add-In ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Scheduled Maintenance
Certificate Generation Provider Maintenance Mar 30, 2024 23:59 - Mar 31, 2024 02:59 UTC
Our certificate provider Sectigo will be carrying out scheduled maintenance during this time on their certificate issuance platform. This means that during the maintenance window they may be unable to provision new certificates. This is expected to last until 0300 UTC 31/03. As a result of this, new office 365 tenants attempting to onboard during this specific time window may be unable to complete the mail routing wizard.
Posted on Mar 27, 2024 - 15:52 UTC
Past Incidents
Mar 29, 2024

No incidents reported today.

Mar 28, 2024
Resolved - Engineers have confirmed that the previous service alert has been resolved.

The service is now back to full health and is working as normal.

Thank you for your patience.

Mar 28, 11:20 UTC
Monitoring - Exclaimer engineers have rolled out a successful fix across all infrastructure by 14:40 UTC and have been monitoring the service.

We will continue to monitor the alert to ensure service stability.

Mar 27, 16:36 UTC
Identified - Behaviour:
When attempting to send a message whilst using the Exclaimer Outlook Add-in, you may receive the following message:

"Unable to download default signature. Status 401"

Investigation:
We have identified a cause of this issue and are in the process of rolling out changes to address it.

Next Steps:
Once the changes are fully rolled out across our infrastructure we will monitor for further reports and be working on a root cause analysis.

Mar 27, 11:11 UTC
Mar 27, 2024
Mar 26, 2024

No incidents reported.

Mar 25, 2024

No incidents reported.

Mar 24, 2024
Resolved - Engineers have confirmed that the previous service alert has been resolved. The maintenance window has completed and certificates have been successfully provisioning again.

The service is now back to full health and is working as normal.

Thank you for your patience.

Mar 24, 03:29 UTC
Monitoring - Our certificate provider Sectigo is currently carrying out scheduled maintenance. This means that until complete, they are unable to provision new certificates. This is expected to last until 03:00 UTC 24/03. As a result of this, new office 365 tenants attempting to onboard will be unable to complete the mail routing wizard. The status of this maintenance event can be viewed on the sectigo status page here: https://sectigo.status.io/pages/maintenance/5938a0dbef3e6af26b001921/65f48a9351261305827a8ad2

Once the maintenance window has cleared, Engineers will verify the status of certificate provisioning and update accordingly.

Mar 24, 01:39 UTC
Mar 23, 2024

No incidents reported.

Mar 22, 2024

No incidents reported.

Mar 21, 2024

No incidents reported.

Mar 20, 2024

No incidents reported.

Mar 19, 2024

No incidents reported.

Mar 18, 2024

No incidents reported.

Mar 17, 2024

No incidents reported.

Mar 16, 2024

No incidents reported.

Mar 15, 2024

No incidents reported.